it-swarm-pt.tech

Existe uma razão convincente para atualizar do Ubuntu 8.04 (Hardy Heron)?

Tanto a minha instalação como a do servidor estão bem. Estou perdendo algo importante que faria uma atualização valer o incômodo?

10
Aviah Laor

A resposta curta seria:

  • Servidor: não
  • Desktop: talvez

O velho ditado "Se não está quebrado, não conserte". é especialmente verdadeiro quando se lida com servidores. Embora eu tenha atualizado meu servidor de 8.04 para 10.04, isso ocorreu apenas porque havia muitas bibliotecas novas que eu realmente queria. Exceto por esse 8,04 ainda é um lançamento sólido, e se não há nada que você explicitamente sente que está faltando, definitivamente eu deveria ficar com ele.

Em relação ao desktop, a escolha é menos óbvia. O novo 10.04 provavelmente dará uma "experiência de desktop" melhor e mais polida. Além disso, você notará muito mais aprimoramentos no software de área de trabalho incluído do que os geralmente feitos com os daemons de servidor comuns.

Ainda assim, a sua área de trabalho 8.04 está funcionando para você e enquanto o mesmo provavelmente irá para o desktop 10.04, uma mudança sempre vem com o risco de algo dar errado. O que eu acho que se resume a quão oneroso/possível seria para você reinstalar o desktop 8.04 no pior cenário possível.

16
andol

Sim, uma enorme quantidade de trabalho proativo de segurança foi feito entre Hardy e Lucid. Basta comparar a lista recursos de segurança . Por exemplo, muitas falhas de segurança que seriam exploradas no Hardy são, no máximo, uma negação de serviço no Lucid.

10
Kees Cook

Depende de quais são suas necessidades. Certamente, no desktop, é mais provável que você atualize porque os aplicativos e os recursos mudam mais e mais rapidamente.

No entanto, também o servidor tem algumas novas atualizações que podem cortar os dois lados. Por exemplo, o php5 foi atualizado para o 5.3, que possui muitos novos recursos relevantes para a linguagem php (namespacing, funções mágicas para métodos estáticos em objetos, etc.). No entanto, muitos aplicativos php antigos não são compatíveis com o php5.3. Portanto, você precisa pesar se algum dos seus aplicativos antigos for afetado e se precisar desses novos recursos.

4
txwikinger