it-swarm-pt.tech

Não é possível atualizar o thunderbird

Eu instalei recentemente o Thunderbird 3.1 de alguma fonte que não era o repositório do Ubuntu. Não me lembro agora de onde peguei (acho que foi empacotado como deb), mas estou tendo um problema quando ele tenta fazer a atualização automática.

Ao contrário das versões que gerenciam suas atualizações através dos repositórios, este deve se atualizar sempre que necessário, o que parece bem, mas sempre que tenta, aparece um erro:

Uma atualização de segurança e estabilidade recomendada está disponível, mas você não tem as permissões do sistema necessárias para instalá-la. Entre em contato com o administrador do sistema ou tente novamente em uma conta que tenha permissão para instalar o software neste computador. Você sempre pode obter a última versão do Thunderbird em: http://mozillamessaging.com/en-US/Thunderbird

Existe uma maneira de fornecer TB as permissões necessárias para abrí-lo como root?

4
mlissner

Não. A única maneira de permitir que o Thunderbird se atualize é lançá-lo como root ou encontrar outra fonte que construa o Thunderbird de tal forma que você possa instalá-lo inteiramente dentro de sua própria pasta pessoal.

Uma opção melhor, se você deseja executar aplicativos de ponta, é tentar encontrar alguém fazendo builds em um PPA do Launchpad. Estes podem atualizar através do sistema normal Synaptic/Upgrade, o que significa que você não vai acabar com casos de canto como este. Por acaso, a equipe da Mozilla mantém um PPA de versões mais recentes do Firefox e do Thunderbird , incluindo até nighties. Se você instalar o Thunderbird 3.1 de lá, você deve ser de ouro.

4
Benjamin Pollack

Eu acabei de atualizar. No lançamento do terminal Thunderbird:

Sudo Thunderbird

Então atualizou com um problema

Boa sorte

Anthony

0
TwoTone