it-swarm-pt.tech

Atualização de firmware para o iPod Touch (iPhone)?

Eu preciso atualizar o firmware do meu iPod Touch (iPhone) no Ubuntu e como eu jailbroken iPod Touch eu preciso do iTunes para instalar aplicativos, mas infelizmente não encontrei nenhuma maneira de fazer isso no Ubuntu ainda. Eu sei que é possível usar VirtualBox ou Wine, mas ainda na maioria das vezes o iTunes não quer trabalhar em Wine e para o VirtualBox eu preciso instalar novamente o Windows do qual eu mudei para o Ubuntu há poucos meses e não quero voltar a ele.

O que os usuários de Linux que têm o iPod Touch (iPhone) fazem neste caso?

Qualquer sugestão para resolver o problema ficará satisfeita.

E, finalmente, quanto tempo levará até Apple desenvolver o iTunes para o sistema operacional Linux?

18
Bakhtiyor

Embora algumas versões mais antigas do iTunes possam atualmente funcionar com o Wine (ou Crossover), elas não podem ser usadas para atualizar ou sincronizar iPods mais recentes

A razão é que o Wine não tem um handler para drivers de dispositivos USB do Windows, e o iPod funciona como um dispositivo USB personalizado. Esta é a mesma razão pela qual o software que requer um dongle de chave especial também não funciona (ainda) no Wine. Existem alguns patches preliminares disponíveis para isso, e você pode ler mais história no Wine wiki , no entanto, não espere nada para trabalhar.

Os únicos iPods que atualmente funcionam no Wine são iPods realmente antigos que funcionam como simples dispositivos de armazenamento em massa USB. E mesmo assim você ainda precisa encontrar um iTunes mais antigo e funcional.

Devido a esse problema no Wine, para fazer a atualização do firmware, você precisará configurar uma máquina virtual com o Virtualbox ou o VMware ou, talvez de forma mais simples, emprestar o computador de outra pessoa.

9
Scott Ritchie

Eu não sei se isso funciona com o seu iPod touch, mas funciona para meus iPods mais antigos: http://code.google.com/p/iPod-update/

4
manyxcxi

Olhando para o Crossoverpágina para o iTunes , um par de versões foram relatados para trabalhar um pouco. Crossover custa dinheiro, mas pode valer a pena para você.

3
Michael Crenshaw

Firmware-Upgrade não funcionou para mim: Ubuntu 8.04 LTS com vmplayer e um antigo XP com o iTunes.

Sem chance. o iphone estava fora de ordem pelo resto do dia até que eu liguei no meu pc do windows no meu lado do trabalho.

Deste ponto de vista: os produtos da Apple são absolutamente inúteis! Por que preciso de um windows ou mac com o iTunes para ter um telefone? Onde é dito que, ao comprar aquela "coisa-a-mágica", eu preciso de um iTunes rodando para que funcione? Quem sabe os custos antes?

3
Ice

libimobiledevice

Ainda é experimental, mas você deve verificar libimobiledevice . Ainda não há GUI, mas eles estão trabalhando para que os modelos do iPod touch funcionem no Linux (incluindo up e downgrade do software).


Edit: De acordo com o buntu Wiki este é o padrão desde pelo menos 14.04 e implementado em vários projetos. Confira as notícias e o status na página do projeto libimobiledevice para detalhes. Atualmente eles afirmam que eles suportam o iOS 9, que ainda estava em beta no momento da escrita.

2
PierreS

Eu me cansei de atualizar o meu firmware do iPhone v2 para v3 usando o iTunes rodando no VMware. O processo parou no meio do caminho e o iPhone ficou inutilizado. Eu conectei as máquinas do windows de um amigo e depois de várias tentativas de atualização, ele voltou à vida.

As atualizações nas mesmas versões principais funcionaram bem no iTunes/VMware.

0
A.B.