it-swarm-pt.tech

Tela preta após o login Kubuntu 15.04

Eu atualizei meu kubuntu 14.10 para o Kubuntu 15.04. E agora, após o boot, quando eu digitar minha senha na tela de boas vindas, eu vou ficar com a tela preta. Parece que a tela está desligada. Sem cursor, sem alterar o brilho. Nada. E quando eu tento mudar para consoles de texto (Ctrl + Alt + F1) nada acontecendo. Se eu não fizer login na tela de boas-vindas, posso mudar para o console de texto.

15
Максим Т

Eu posso ter uma solução, eu tenho tentado descobrir o que aconteceu por alguns dias agora. Deletar todos ~/.cache e ~/.config não é uma ótima idéia, já que podem ser necessários, mas. . .

Em ~/.cache, eu deletei somente os arquivos com um DVD de boot 14.04, mas mantive as pastas:

activityswitcher_wallpaper_preview.kcache
event-sound-cache.tdb.093cbe7e51f0423cb8a1384115f450a1.x86_64-pc-linux-gnu
icon-cache.kcache
ksycoca5
ksycoca5stamp
motd.legal-displayed (0 kb)
plasma-svgelements-air_v1.0
plasma-svgelements-breeze-dark_v0.9.7
plasma_theme_breeze-dark_v0.9.7.kcache
[...]
plasma_wallpaper_preview.kcache

Após a reinicialização, a área de trabalho estava bem.

5
Guillaume

Acabei tendo que renomear ~/.kde, ~/.cache ~/.local e ~/.config.

mv ~/.kde ~/.kde.old
mv ~/.cache ~/.cache.old
mv ~/.local ~/.local.old
mv ~/.config ~/.config.old
shutdown -r now

Não sei exatamente qual deles fez o truque, mas eu suspeito que era .config.

7
StFS

Isso me incomodou por algum tempo agora. Eu notei que isso acontece quando eu coloco o Kubuntu para dormir ou desligo com uma configuração de dois monitores e, em seguida, tento iniciá-lo apenas com a tela do laptop. Enfim, aqui está o que eu encontrei - uma pasta específica é responsável por essa bagunça. A exclusão corrige meu problema.

Veja o que fazer. Depois de obter a tela preta, vá para um tty (Ctrl + Alt + F1) e faça o seguinte:

 rm ~/.local/share/kscreen
 Sudo killall sddm

Em seguida, digite sua senha e faça o login. Tudo deve estar bem. Espero que isto ajude ;)

5
Branko

Eu também tive o mesmo problema na nova instalação do kubuntu 15.04 64 bit.

  1. Pressione Ctrl+Alt+F1 depois que o sistema foi iniciado
  2. Sistema irá pedir para entrar dar seu nome de login e pressione enter
  3. Digite a senha

    mv ~/.kde ~/.kde.old
    mv ~/.cache ~/.cache.old
    shutdown -r now
    
  4. Se você puder colocar seu gui na próxima inicialização, não esqueça de alterar 'iniciar com sessão vazia' em 'sessão de desktop' em 'Configurações do Sistema'

3
DroidDom

Eu tive o mesmo problema; O problema era que eu tinha duas versões diferentes dos drivers nvidia instalados. Parece que o dist-upgrade foi instalado automaticamente nvidia-340, então apenas execute o comando abaixo e então reinicie e você deve estar bom.

Sudo apt-get purge nvidia-340*
1
iplaman

Eu tenho o mesmo problema. Depois de passar por alguns blogs e fóruns me deparei com solução, mas não funcionou para mim. Vale a pena tentar seguir os comandos e ver se resolve o seu problema.

mv ~/.kde ~/.kde.old
shutdown -r now
0
Jhones

Então eu enfrentei esse problema depois de mudar a senha do meu usuário, e só consegui resolver isso depois de alterá-lo de volta para o antigo através do comando 'passwd'.

0
Waqleh

TL; DR: Verifique se você tem espaço suficiente em /var, /, /home. Espaço insuficiente impede que o servidor xOrg seja iniciado.

Para obter o sistema de volta, você pode executar startx no terminal, o que deve lhe dar algumas dicas, como indicado por este thread reddit . Este comando inicia o servidor xOrg. A solução proposta no thread reddit com a mudança ~/.xinitrc não funcionou para mim.

Se startx realmente recuperasse seu sistema, você poderia reinicializar, voltar ao terminal e verificar se o xserver não está rodando executando xset q as indicado aqui . Como echo $DISPLAY não retornou nada para mim, eu encontrei estas soluções , como startkde não funcionava também (startkde iniciava a sessão do kde). Mais importante ainda, /var, /, /home deve ter espaço suficiente (verifique o uso do disco com df -h).

Essas soluções finalmente provaram ser dignas, pois eu simplesmente não tinha mais espaço. Depois de limpar alguns arquivos e reinicializar, o KDE foi iniciado normalmente.

0
Elektropepi

Seguindo os passos trabalhados para mim.

  1. No menu do grub, selecione "configurações do sistema", que o colocará no menu da bios.
  2. Ver ordem de inicialização (não são necessárias alterações).
  3. Salvar mudança e sair.

Arranque após os passos 1-3 impede o ecrã em branco. Eu não sei como, mas funcionou bem para mim.

0
Varghese