it-swarm-pt.tech

Problema de atualização automática do WordPress 3.0.1

Meu WordPress agora está na versão 2.7. Eu quero atualizá-lo para o 3.0.1 usando a função de atualização automática. Estou usando o tipo de conexão FTPS.

A atualização deve ser direta, mas continuo encontrando este erro:

Instalação Falha ao fazer o download da atualização de http://wordpress.org/wordpress-3.0.1.Zip

Desembalando a atualização ...

Verificando os arquivos descompactados ...

Instalando a versão mais recente…

Não foi possível copiar o arquivo .: /wp-admin/css/theme-editor.dev.css

Instalação falhada

Eu verifiquei a permissão para a pasta /wp-admin/css e ela está configurada para 777.

Qual é o problema? Eu pesquisei na internet, mas parece que muitas pessoastem o mesmo problema .

Alguma ideia?

2
Graviton

A atualização automática nem sempre funciona, quase sempre funciona. Eu acabei de atualizar manualmente e não me preocupo com isso. As poucas vezes em que tive uma falha de atualização automática são bem-sucedidas na próxima vez que uma nova versão for lançada (depois que eu for atualizada manualmente durante a quebra).

2
curtismchale

Há um patch (http://core.trac.wordpress.org/ticket/10913) para o WordPress que deve entrar em 3.2 e ajudar a corrigir este erro de atualização para a maioria das pessoas que o executam. Parece apenas acontecer com servidores que executam o Pure-FTPd. Enquanto isso, há um plug-in que deve ajudar a corrigir atualizações para a maioria das pessoas: http://wordpress.org/extend/plugins/ftp-upgrade-fix/

2
user3757

Verifique o proprietário do arquivo/s você pode tê-lo definido 777, mas se o serviço de ftp não está no grupo de proprietário ou o proprietário isso pode o seu problema

Você precisa telnet no servidor web para verificar/corrigir isso nos ls -l para ver as configurações chown é a forma como você alterá-lo

0
Pbearne

Eu tentei de tudo para a atualização automática que foi mencionada em wordpress.org/support/topic/upgrade-gone-worng-pls-help, mas sem sucesso.

Em vez disso, fiz uma atualização manual mais ou menos seguindo as instruções em codex.wordpress.org/Upgrading_WordPress. Em vez de usar o FTP, eu usei meus provedores de hospedagem CPanel - eu, então, escrevi os passos que fiz para que outros pudessem se beneficiar - veja http://misterjaytee.com/2010/09/11/errors -updating-wordpress .

Espero que a próxima atualização automática funcione corretamente, mas se não, eu agora tenho a confiança para fazer a atualização manualmente.

0
misterjaytee
0
Nabeel

Verifique as permissões no arquivo referenciado. Neste caso: /wp-admin/css/theme-editor.dev.css.

0
artlung